[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4779: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4781: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4782: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4783: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
Gentoo Taiwan 討論區 • 檢視主題 - 請問ruby

請問ruby

Gentoo 管理、通用套件相關問題 (如 iptables、apache、*sql、*ftpd...) 請在此討論。

版主: Forums Team

請問ruby

文章samuel » 週六 3月 13, 2010 9:52 pm

我是個100%的ruby 新手
但是最近要裝一個軟體會用到ruby
所以我打算來建構ruby的環境

但是問題就這麼來了
我裝的是ruby 1.8的版本
但是那個軟體需要ruby的套件

我有搜尋了一陣子
安裝上基本上是ruby + rubygems
套件的部分大致上是說portage 裡面有的就用( dev-ruby/<xxx> )
如果找不到的話 就用gem install 來裝

我有嘗試著要裝ruby 1.9
但是許多dev-ruby/<xxx> 下面的套件只允許ruby 1.8 compile
無奈,我只好選擇ruby 1.8
抑或是選擇另外一條路 ruby 1.9 + gem的方式

可是我在搜尋的過程中
有人又說gem 是ruby的一種痛?
令我心裡毛毛的
大致上是說能裝portage 內的就裝
不得已才用gem install來安裝

但....我怎麼裝似乎都有問題
一直造成Undefined namespace prefix 問題
無奈我對ruby 一竅不通,完全沒概念

別人妝都沒問題 我倒是問題一堆 Q_Q


想請問安裝上是否正確?
再來就是錯誤訊息該朝甚麼方向解決?
samuel
 
文章: 43
註冊時間: 週五 3月 14, 2008 1:51 am

Re: 請問ruby

文章samuel » 週六 3月 13, 2010 10:34 pm

samuel
 
文章: 43
註冊時間: 週五 3月 14, 2008 1:51 am

Re: 請問ruby

文章Jackie » 週六 3月 20, 2010 9:26 am

我也不懂ruby
不過這邊找到一些東西你參考看看

http://technicalpickles.com/posts/manag ... on-gentoo/
http://blog.flameeyes.eu/2008/12/14/rub ... -languages
http://bugs.gentoo.org/164369

我覺得如果先用portage裡面的ruby...然後又用rubygems去裝東西
可能會遇到一些討厭的問題 而且用得越久就越糟

若套用perl的經驗...perl相對於gems的東西叫cpan
可是portage裡面有一個套件叫作g-cpan
他能從cpan那邊抓perl的module的資訊然後把她轉成ebuild 相當方便
只不過我目前還沒找到ruby有相對應的東西

或許大多人都還是用python吧...
所以ruby的東西在gentoo裡面好像維護的人不多

更新:
我後來發現Gentoo官方的page就有有用的資源(之前看漏了)
http://www.gentoo.org/proj/en/prog_lang/ruby/index.xml
http://overlays.gentoo.org/proj/ruby/wiki
其中第二個是ruby的overlay
我覺得你可以用這個overlay
如果裡面已經有的套件就用這個裝(不要用gems)
不行的話再試試它裡面的 (與上面提到的g-cpan相對應的工具)
然後套件最後還是都給portage管理
這樣整個系統才會乾淨
Jackie
 
文章: 137
註冊時間: 週六 7月 08, 2006 10:13 pm

Re: 請問ruby

文章samuel » 週六 3月 20, 2010 12:37 pm

沒錯 這也是我困惑的地方
我上irc 問過一些人 他們也說rubygems 是他們永遠的痛 @@!

我所得到的結果
1. 全部用rubygems
2. 全部用portage
3. 自己包ebuild :shock:

這是為了clean 才這麼做
通常一致認為portage > *
ruby套件可以從portage 來裝的大好!
沒有的話 會自己包的話就自己包
下下策才是裝rubygems

而關於怎麼包ebuild
flameeyes 又提到有新的eclass ruby-ng 可以用
並教導大概怎麼包ruby 套件的ebuild
http://blog.flameeyes.eu/2010/02/15/rub ... uby-ebuild

他的目的是為了改善ruby 套件在emerge 過程中所能處理的階層更低
維護dependency 和整個系統乾淨
而不再只是gem 的「下載、安裝」沒了

總之沒想到ruby 在gentoo 上有這樣的問題 :shock:
g-gem 我倒是還沒試過
我找找文章比較看看 ..

感恩回復!!
samuel
 
文章: 43
註冊時間: 週五 3月 14, 2008 1:51 am

Re: 請問ruby

文章Jackie » 週日 3月 21, 2010 12:34 am

Jackie
 
文章: 137
註冊時間: 週六 7月 08, 2006 10:13 pm


回到 Gentoo 服務與管理

誰在線上

正在瀏覽這個版面的使用者:Google [Bot] 和 1 位訪客

cron